Vanilla requires PHP 5.3 or greater.